Starburst ODBC driver#

The Starburst ODBC driver allows any client application with ODBC support to connect to Starburst Enterprise platform (SEP). Once connected, SQL statements can be used to query catalog, and therefore the underlying data sources.

You must meet the minimal system requirements for installing the ODBC drivers on Windows, Mac, or Linux. Operating system specific packages and installers are available.

Detailed information is available in the comprehensive ODBC driver documentation.

Installation#

The driver can be downloaded from the Starburst Support site.

The ODBC driver requires a license –– contact Starburst Support for your license file.

Run the ODBC installer. Note the installation path /Library/starburst/prestoodbc/ on MacOS. The driver documentation contains more details, including paths for different platforms.

Copy your license (.lic) file to the lib directory in the ODBC driver installation, for example /Library/starburst/prestoodbc/lib/.

Supported platforms#

Windows

  • Windows 7 SP1, 8.1, or 10

  • Windows Server 2008 R2 SP1, 2012, or 2016

MacOS

  • OSX version 10.12, 10.13, or 10.14

Linux

  • Red Hat® Enterprise Linux® (RHEL) 6 or 7

  • CentOS 6 or 7

  • SUSE Linux Enterprise Server (SLES) 11 or 12

  • Debian 8 or 9

  • Ubuntu 14.04, 16.04 or 18.04

Older versions of the driver may be subject to different platform requirements.

SEP version requirements#

In general you should use the latest available version of the ODBC driver independent of your SEP version.

The information in the following table is for completeness only.

ODBC version by SEP release#

SEP version

ODBC driver version

354- and higher

1.2.14

302-e to 350-e

1.2.7, 1.2.10 or 1.2.14

195-e to 213-e

1.2.2